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[N.B: Answer all Questions.] 

  Marks 
I Fill in the blanks: 10 x 1 = 10 
 1. Transformation of input to output is performed by CPU.   

 2. Folder is a named location on a disk where files are stored. 

 3. Wall  command in Linux system is used to write a message to all users. 

 4. Insert  tab is used to add a table to a document. 

 5. Long text can be broken into many lines within cell by Wrap text option in 
formatting. 
 

 6. OpenOffice keeps a list of recently opened files under the File / Recent 
Documents  menu. 
 

 7. In Access, Tables are used to store the data. 

 8. Static  reports contain the data in the selected fields at the time the 
report was created, in OpenOffice base. 
 

 9. In MS Power Point F5  key is used to run the slide show from the 
beginning. 
 

 10. Cc in email is Carbon Copy 
 

 
II Match the following: 10x1=10 

 1. Joy stick    input device  

 2. Android  operating system  

 3. Cd  change directory  

 4. Copy  & Paste    clipboard  

 5. Word  mail merge  

 6. Record    collection of field    

 7. Base    ODBC  

 8. Impress  slide transition    

 9. Calc   calculation  

 10. Hub     network device  

[Turn over... 
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III Choose the best answer: 10 x 1 = 10 

 
 1. The ________ are not performed by the Computer. 

  a. storage and retrieval operations b. logic operations 

  c. arithmetic operations d. printing of documents  
 

 

 2. File ___ shrinks the size of a file so it requires less storage space. 
 

  a. compression b. defragmenting c. synthesizing d. scanning 
 

 3. Which one is not a tab in Microsoft Word 2010? 
 

  a. File     b. Insert    
  c. Home   d. Design  

 

 4. Which of the following file extension is not compatible with OpenOffice 
Writer? 
 
 

  a. txt b. doc c. sxw    d. csv 
 

 5. Page border in Excel; can be set 
 

  a. from border tab in format 
cells dialog box 

b. from border tool in formatting 
toolbar 

  c. from line style in drawing 
toolbar  
 

d. from Insert tab. 
 

 6. The place where accessories are connected in Computer is 
 

  a. Port b. Ring c. Bus d. Zip 
 

 7. The size of yes/no field is always ____ in OpenOffice base. 
 

  a. 1 bit b. 1 byte 
  c. 1 character d. 1 kB 

 
 8. Which tool do you use to create a query object? 

 

  a. Table query wizard b. Simple query wizard 
  c. Simple filer wizard d. Database wizard 

 

 9. The file that consists of readymade styles that we can easily use for our 
presentation is known as: 
 

  a. Pre formatting b. Template c. Wizard d. AutoStyle  
 

 10. Which of the following command is used to count the total number of lines, 
words, and characters contained in a file? 
 

  a. wc b. wcount 
  c. countw d. cw 

 
 



IV Say TRUE or FALSE: 10 x 1 = 10 

 1. Auxiliary memory is popularly known as primary memory.             False 

 2. When a file is moved to recycle bin, it will be immediately deleted from 
the computer.                                                                            False 
 

 

 3. Directory is a type of file in Linux.                                                True 

 4. Pressing the Printscreen key on your keyboard takes a 'picture' of what 
is displayed on the screen.                                                           True 
 

 5. Nested tables cannot be created in OpenOffice writer.                    False 

 6. If a formula consisting of relative references is copied from one cell to 
another, it will still be the same.                                                  False 
 

 7. In Excel, you can view the worksheet page wise with page break.  True 
 
 

 8. In Excel, logical values are represented by numbers.                     True 

   9. In Impress, placeholders are areas on the slide that are enclosed by 
dotted borders.                                                                          True 
 

 10. A network location of a web page is a URL.                                   True 
 
 

V Write short answers for any Fifteen Questions from the following: 15 x 2 = 30 

 1. List the types of computer on the basis of working. 

Analog, digital and hybrid computer.  
 2. Differentiate ROM and RAM.  (any two points) 

RAM ROM 
RAM stands for Random Access 
Memory. 

ROM stands for Read Only Memory. 

RAM is a primary memory of the 
computer that stores those data and 
instructions on which the CPU is 
currently working. 

ROM is a primary memory of the 
computer that stores those computer 
instructions and programs that do not 
need to be altered in future like 
BIOS. 

RAM is a volatile memory. Which means 
it stores data as long as power is on. 

ROM is a non-volatile memory that 
means it stores data permanently 
even when power is off. 

RAM is used to store data that CPU 
needs for current instruction processing. 

ROM is used to store data that in 
needed to bootstrap the computer. 

There are two major types of RAM 
available – SRAM (Static Random 
Access Memory) and DRAM (Dynamic 
Random Access Memory). 

Three types of ROM available – 
PROM (Programmable ROM), 
EPROM (Erasable PROM), and 
EEPROM (Electrically EPROM). 

The speed of RAM is quite high. The speed of ROM is slower than 
RAM. 

RAM memory is large and high capacity. ROM is generally small and of low 
capacity. 

RAM is used as CPU Cache, Primary 
Memory. 

ROM is used as firmware by 
microcontrollers. 

RAM is costly. ROM is not so expensive. 
 



 3. Define operating system. What is multi-tasking operating system? 

An operating system (OS) is the program that, after being initially loaded into the 

computer by a boot program, manages all of the other application programs in a 

computer.It is the interface between human and computer. 

Multitasking, in an operating system, is allowing a user to perform more than one 

computer task (such as the operation of an application program) at a time. 

 4. What is quick launch tool bar? 

The Quick Launch toolbar provides an area for PC users to place shortcuts to 

their most frequently used programs. 

 5. What are the components of Linux? 

The Linux operating system is made up of three parts; the kernel, the shell, and 

the programs. 

 6. How the text can be aligned in a Writer? 

1. Click anywhere in the paragraph that you want to align. 

2. On the Home tab, in the Paragraph group, do one of the following: 

To Click 

Align text left Align Text Left   

Center text Center Text   

Align text right Align Text Right   
 

 7. How to insert a table in MS Word? 

click Insert > Table and move the cursor over the grid until you highlight the 

number of columns and rows you want.  

For a larger table, or to customize a table, select Insert > Table > Insert Table. 

 8. How to set the page break in MS Word? 

Go to Layout > Breaks > Page. 

1. Click or tap in the document where you want a page break. 

2. Go to Insert > Page Break. 

 9. What is relative cell reference? 

Relative reference is the default cell reference in Excel. It is simply the 

combination of column name and row number without any dollar ($) sign. When 

you copy the formula from one cell to another the relative cell address changes 

depending on the relative position of column and row. 



 10. What are the types of spread sheet? 

● Small databases. 

● Models. 

● Business Processes. 

 

 11. What is a cell in Calc? How it is addressed? 

The cell is the intersection between the row and the column on the spreadsheet. 

Each cell in spreadsheet has unique address/ reference which is defined by its 

column letter (A,B...) and row number (1,2...). 

 12. What are the types of reports in Base? 

Static report   

Dynamic report  

 

 13. How to create a database? 

Right-click Databases, and then select New Database. In New Database, enter a 

database name. To create the database by accepting all default values, select OK. 
 

  

14. What is a query? 

A query is a request for data or information from a database table or 

combination of tables.  

 

 15. What is master template in Impress? 
 
A slide master is a slide that is used as the starting point for other slides. It is 
similar to a page style in Writer: it controls the basic formatting of all slides based 
on it. A slide which is used to create other slides. 
 

 16. How to add text to the presentation? 
 

1. On the Home tab, under Insert, click Text. 
2. On the pop-up menu, click Text Box. 
3. On the slide, click the location where you want to add the text box. 
4. Type or paste your text in the text box 

 
 17. What is topology? 

 
A topology is the physical and logical arrangement of nodes and 
connections in a network. 



 18. Differentiate LAN and WAN. ( any two) 

LAN WAN 

The full form of LAN is Local Area 
Network. 

The full form of WAN is Wide Area 
Network. 

LAN is private. WAN can be private or public. 

When it comes to LAN, the 
propagation delay is shorter. 

In the case of WAN, the propagation 
delay is longer. 

The speed of LAN is higher. The speed of WAN is slower. 

In LAN, the blockages are less. In WAN, the blackages are more. 

The configuration and 
maintenance is easy in LAN. 

The configuration and maintenance is 
harder than LAN. 

In LAN, the fault tolerance is 
more. 

In WAN, the fault tolerance is less. 

LAN covers smaller areas like 
school, hospital, etc. 

WAN covers a large area like a country. 

Coaxial or UTP cable is the 
transmission medium used by 
LAN. 

PSTN or satellite link is a transmission 
medium used by WAN. 

 

 
  



 
VI Write answers in detail:                                                                         6 x 5 = 30 

 1. (a) What are the components of CPU? Explain.    

 

 
 
 

Register Set 
The register set contrasts from one system to another. The register set 
includes several registers which contain general-purpose registers and 
special-purpose registers. The general-purpose registers do not implement 
any particular function. They save the temporary information that is needed 
by a program. The special-purpose registers execute various functions for 
the CPU. 
ALU 
The ALU implements all the arithmetic, logical, and shift operations by 
supporting important circuitry that provides these evaluations. 
Control Unit 
The control unit fetches the instructions from the main memory, decodes the 
instructions, and then executes them. 
The CPU interacts with the main memory and input/output devices. The CPU 
reads and writes data to and from the memory system and transfers data to 
and from the I/O devices. 
 
Motherboard The motherboard is the computer's main circuit board. 
Hard disk The hard drive is where your software, documents, and other files 
are stored. 
RAM (Random Access Memory) 
SMPS & Connecting wire 
Connecting wires 
20 + 4 Pin ATX / Motherboard Connector 
CPU 4 + 4 Pin Connector 
SATA Power Connector 
Floppy 4 Pin Connector 
Peripheral 4 Pin Molex Connector 
PCI-e 6 Pin / PCI-e 8 Pin Connector 
Graphics Card 
Sound Card 
Network Interface Card 
Modem 

       (Or) 



 1. (b) Explain about the memory units. 
 

 Memory Unit All the data that has to be processed or has been processed is 

stored in the memory unit. The memory unit acts as a hub of all the data. It 

transmits it to the required part of the computer whenever necessary. The 

memory unit works in sync with the CPU. This helps in faster accessing and 

processing of the data. Thus, making tasks easier and faster.  

There are two types of computer memory  

1. Primary memory – This type of memory cannot store a vast amount of 

data. Therefore, it is only used to store recent data. The data stored in this is 

temporary. It can get erased once the power is switched off. Therefore, is 

also called temporary memory or the main memory. RAM stands for Random 

Access Memory. It is an example of primary memory. This memory is directly 

accessible by the CPU. It is used for reading and writing purposes. For data 

to be processed, it has to be first transferred to the RAM and then to the 

CPU.  

2. Secondary memory – As explained above, the primary memory stores 

temporary data. Thus it cannot be accessed in the future. For permanent 

storage purposes, secondary memory is used. It is also called the permanent 

memory or the auxiliary memory. The hard disk is an example of secondary 

memory. Even in a power failure data does not get erased easily. 
  



 2. (a) Explain mail merge.   

  Mail Merge is a useful tool that will allow to produce multiple letters, labels, 

envelopes, nametags, and more using information stored in a list, database, or 

spreadsheet. While performing a Mail Merge two documents are required (1) 

Word document (also can start with an existing one or create a new one) and 

(2) a recipient list, which is typically an Excel workbook.  

To use Mail Merge  

1. Open an existing Word document, or create a new one.  

2. Click the Mailings tab.  

3. Click the Start Mail Merge command.  

4. Select Step by Step Mail Merge Wizard. 

The Mail Merge task pane appears follow the six main steps to complete a 

merge. The following is an example of how to create a form letter and merge 

the letter with a recipient list. 

Step 1: 1. Choose the type of document you want to create. In this example, 

select Letters. 2. Click Next: Starting document to move to Step 2. 

Step 2: 1. Select Use the current document. 2. Click Next: Select recipients to 

move to Step 3. 

Step 3: From the address list so Word can automatically place each address 

into the document. The list can be in an existing file, such as an Excel 

workbook, or type a new address list from within the Mail Merge Wizard. 1. 

From the Mail Merge task pane, select Use an existing list, then click Browse. 

2. Locate your file in the dialog box, then click Open. 3. If the address list is in 

an Excel workbook, select the worksheet that contains the list, then click OK. 

4. In the Mail Merge Recipients dialog box,can check or uncheck each recipient 

to control which ones are used in the merge. Click OK to close the dialog box. 

5. From the Mail Merge task pane, click Next: Write your letter to move to Step 

4. 

Step 4: When it is printed, each copy of the letter will basically be the same, 

except the recipient data—like the name and address—will be different on each 

one. Add placeholders for the recipient data so Mail Merge knows exactly 

where to add the data. In this step if the Mail Merge is with an existing letter, 

make sure the file is open. 

Step 5: 1. Preview the letters to make sure information from the recipient list 

2. Click Next: Complete the merge, followed by printing. 

       (Or) 
  



 2. (b) Explain about the formatting of documents in Writer.  

  In Apache OpenOffice, you can apply formatting to documents in two 

different ways. You can do so directly using menus and toolbars, or you 

can use styles and templates. To a new user, it may seem easier to 

format a document directly, applying formatting only as needed. 

However, this can be repetitive, and problematic when working with 

longer documents. You can save yourself a lot of time and trouble by 

using styles and templates, which cause your document to follow 

predefined formatting rules. While this may seem complex at first 

glance, it is actually an easy-to-learn tool that affords a great deal of 

flexibility and consistency when authoring documents. Styles can be 

used in all Apache OpenOffice programs with the exception of Apache 

Math. 

Benefits of Styles Over Direct Formatting Suppose we have written 

a long report that is divided into chapters, each marked by a heading. 

We need these headings to be displayed in a particular sans serif font. 

We also need these headings to be displayed in large, bold text, and 

centered on the page. To apply this formatting manually, we would need 

to set up the following formatting for each heading individually: 

"Liberation Sans, 16 point, bold, centered..." 

Adding Styles to Your Document You can create, edit, and apply 

styles to your document through the 'Styles and Formatting' panel. 
  



 3. (a) Write the steps to create and print chart in Calc.      

  Creating Charts 

● Open OpenOffice Calc and enter data  

● Click the Insert menu  Chart  

● Cart and Chart wizard will appear  

● Choose Chart type (Column, Bar , Pie,…) Click Next  

● Select the data range, then click Next  

● Customise the Data range  

● Add chart title , x-axis, y-axis  

● Choose Left/Right/Top/Bottom from Display Legend Radio Button  

● Then Click Finish Button 

 

Printing Chart 

 ● Select format Page from the main menu  

● Select the sheet tab  

● Specify which details to print  

● Click charts check box, then click ok button  

● Then click File Menu Print. 

 

       (Or) 
  



 3. (b) Explain how to set formulae in Excel.  

  Simple formulas always start with an equal sign (=), followed by 

constants that are numeric values and calculation operators such as 

plus (+), minus (-), asterisk(*), or forward slash (/) signs. 

 

example of a simple formula. 

 

To add together the numbers 2, 7 and 1, type the following into any 

Excel cell: = 2 + 7 + 1 which returns the result 10. 

As with all Excel formulas, instead of typing the numbers directly into 

your addition formula, you can use references to cells containing 

numbers. The Excel addition formula in cell A1 of the spreadsheet on the 

right adds together the contents of cells B1, B2 and B3 (which contain 

the values 2, 7 and 1). Again, the formula returns the value 10. 

The Excel Sum Function Instead of using the + operator, you can use 

the Excel Sum Function to perform addition in Excel. The syntax of this 

function is: =SUM( number1, [number2], ... ) where number1, 

[number2], etc. are one or more numbers (or references to cells 

containing numbers) that you want to add together. 

An example of the Excel Sum function is shown in cell A1 of the 

spreadsheet on the right. In this example, the Sum function is used to 

add together the three values in cells B1, B2 and B3 (i.e. the values 2, 7 

and 1). Again, the function returns the value 10. 
  



 4. (a) Explain about importing data from other databases in 
Access.     

  1. On the External Data tab, in the Import & Link group, click the 

command for the type of file that you are importing from. For example, 

if you are importing data from an Excel worksheet, click Excel. If you 

don't see the correct program type, click More.  

2. In the Get External Data dialog box, either click Browse to browse to 

the source data file, or type the full path of the source data file in the 

File name box.  

3. Click the option that you want under Specify how and where you want 

to store the data in the current database. You can create a new table by 

using the imported data, or create a linked table that maintains a link to 

the data source.  

4. Click OK. Depending on your choice, the Link Objects dialog box or 

the Import Objects dialog box opens.  

5. Use the dialog box to finish the process. The exact procedure you 

follow depends on the import or link option that you choose 

6. On the last page of the wizard, click Finish. If you chose to import, 

Access asks whether you want to save the details of the import 

operation that you just completed.  

7. If you think that you will be performing this same import operation 

again, click Save import steps, and then enter the details. You can then 

easily reproduce the import operation by clicking Saved Imports in the 

Import group on the External Data tab, clicking the import specification, 

and then clicking Run.  

8. If you don't want to save the details of the operation, click Close. 

Access imports the data into a new table, and then displays the table 

under Tables in the Navigation Pane. 

       (Or) 
  



 4. (b) Explain about creating of reports in Base. 
 

  Reports provide information found in the database in a useful way. In 

this they are similar to queries. Reports are generated from the 

database's tables or queries. They can contain all of the fields of the 

table or query or just a selected group of fields.  

1. Create a new report.  

a. Click the Reports icon in the Database list in the Automobile - 

OpenOffice.org window.  

b. In the Tasks list, click Use Wizard to Create Report. The Report 

Wizard window opens.  

2. Select the fields. 

 a. Select Table: Vacations in the Tables or Queries dropdown list.  

b. Use the > to move these fields from the Available fields list to the 

Fields in report list: Date, Motel, Tolls, Miscellaneous, Breakfast, Lunch, 

Supper, and SnackCost. Click Next.  

3. Label the fields: answering the question How do you want to label the 

fields. Shorten Miscellaneous to Misc. Click Next.  

4. Since we are grouping by the date, use the > button to move the 

Date field to the Grouping list. Click Next. 

5. Sort options. We do not want to do any additional sorting. Click Next. 

6. Choose layout. We will be using the default settings for the layout. 

Click Next.  

7. Create report.  

Label the report: Vacation Expenses.  

Select Static report.  

Click Finished. 
  



 5. (a) Write the steps for setting Animations in MS Power Point. 

  Step 1 − Go to the Animation ribbon and click on the Animation Pane to 

display the animation sidebar.  

Step 2 − Select one of the objects in the slide and click on the Add 

Animation menu option. 

Step 3 − Choose from one of the Animation options.  

● Entrance will cause the object to appear in the screen.  

● Emphasis will cause the object to emphasis without appearing or 

leaving the screen.  

● Exit will cause the object to disappear from the screen 

Step 4 - Once you add the animation for an object, it will show up in the 

Animation pane. 

Step 5 − By default, all the animations are initiated by a click, but you 

can change this. To change the trigger, right-click on the animation 

object on the pane and choose an alternate trigger. 

● Start On Click will cause the animation to start when you click the 

mouse.  

● Start With Previous will cause the animation to begin with the previous 

animation; if this is the first object, it will begin as soon as you reach 

the slide during the slide show.  

● Start After Previous will cause the animation to begin after the 

previous animation ends. 

Step 6 − From the timing section, you can also manipulate the 

animation timings.  

Step 7 − To preview the animation settings, just click Play on the 

animation pane. 

 
       (Or) 

  



 5. (b) Explain about printing handouts in Impress. 

  Handouts In the Handout view you can check, how the documents for 

the listeners look like. If you prefer another sharing out of the slides, 

you can change the Layout in the Task pane on the right side. This 

selection is used after a mouse click for all pages of the handout. 

 

Printing If you want to print your presentation directly, you can click the 

Printer button (printer symbol) in the Standard bar. Special adjustments 

can be done in the menu File > Print. Here you can define if all pages 

should be printed, or only individual pages. When you click the Options 

button a dialog box will appear, where you can define, that notes or 

handouts should be printed too. 
  



 6. (a) Explain about the applications of Google Forms and Google 
Sheets.   
 

  Applications of Google Forms  
1. Google forms are used to create surveys to meet curriculum 
objectives 
 2. Can be used to ask Various Types of Questions like  
● Text ● Paragraph Text ● Multiple Choice ● Checkboxes ● Choose from 
a list ● Scale ● Grid ● Date ● Time  
3. Possible to Apply Validation Options to Control Data Entry  
4. Google Forms helps to Create Professional Looking Forms using 
Themes  
5. Google Forms helps us to collect data using multiple methods.  
● A form can be included in the body of an email allowing a respondent 
to submit their responses from their Inbox.  
● A link can be generated allowing respondents to answer the questions 
using a web-based form.  
● Code can be generated and then embedded into a blog or web page as 
another option for data collection.  
 
Applications of Google Sheets  
1. Editing  
One of the key features of Google Sheets is that it allows collaborative 
editing of spreadsheets in real-time. Rather than emailing one document 
to multiple people, a single document can be opened and edited by 
multiple users simultaneously. Users can see every change made by 
other collaborators, and all changes are automatically saved to Google 
servers. Google Sheets also includes a sidebar chat feature that allows 
collaborators to discuss edits in real-time.  
2. Explore  
The Explore feature in Google Sheets was first introduced in September 
2016, and it uses machine learning to bring additional functionalities. 
This feature provides a lot of information based on the data added to the 
spreadsheet, and it can auto-update itself depending on the selected 
data. With the Explore feature, users can ask questions, build charts, 
visualize data, create pivot tables, and format the spreadsheet with 
different colors.  
3. Offline editing  
Google Sheets supports offline editing, and users can edit the 
spreadsheet offline either on desktop or mobile apps.  
4. Supported file formats 
 Google Sheets supports multiple spreadsheet file formats and file types. 
Users can open, edit, save or export spreadsheets and document files 
into Google Sheets. Some of the formats that can be viewed and 
converted to Google Sheets include: .xlsx, .xls, .xlsm, .xlt, .xltx, .xltxm, 
.ods, .csv, .tsv  
5. Integration with other Google products  
Google Sheets can be integrated with other Google products such as 
Google Form, Google Finance, Google Translate, and Google Drawings. 
For example, if you want to create a poll or questionnaire, you can input 
the questions in Google Forms, and then import the Google Forms into 
Google Sheets. 

       (Or) 



 6. (b) Explain the different types of Computer Networks. 

  Types of Computer Networks 1. Local Area Network (LAN) 2. 

Metropolitan Area Network (MAN) 3. Wide area network (WAN) 4. 

campus area network (CAN) 5. Home Area Networks (HAN) 

LAN(Local Area Network) 

o Local Area Network is a group of computers connected to each 

other in a small area such as building, office. 

o LAN is used for connecting two or more personal computers 

through a communication medium such as twisted pair, coaxial 

cable, etc. 

o It is less costly as it is built with inexpensive hardware such as 

hubs, network adapters, and ethernet cables. 

o The data is transferred at an extremely faster rate in Local Area 

Network. 

o Local Area Network provides higher security. 

 
Wide area network (WAN) is a telecommunication network that is used 

for connecting computers and covers a wide geographical area. WANs 

often contain a few smaller networks (LANs, MANs, etc.).A WAN span 

across city, state, country or even continent boundaries. 

 

*** 


